805.640.1458    linkedin   facebook   rss

How do you want to grow your business today?        

Most sites done recently in WordPress are updated automatically. However this is just part of the solution for your website security. So it is important that you have current backups so that if needed, you can recover your site. If you need to do a manual upgrade, you can.

It is possible that the widgets or themes you have installed may pose a security risk. The challenge with security is that themes and widgets are available from many developers. Most of these will be generally safe to use. However if you unfortunately use a theme or widget with security vulnerabilities you may still be vulnerable.

Obviously prevention is important. Unfortunately this has become more difficult with WordPress. Landau Design repaired two WordPress sites recently that had the automatic update feature enabled. Both had database injections so it required cleaning that content page by page. Even the installation of our favorite WordPress security widget did not prevent the problems.

We beleive the issue in these cases was the low level shared hosting environment. If you need to host outside your organization, it is wise to consider a SSL certificate and a virtual dedicated hosting arrangement.

December 2016 saw the release of WordPress 4.7 and more robust sites experienced better performance because it supports php 7. It also cleans up some small interface issues in the administrative tools.